OK, så jeg tog fejl – men ikke om .NET 4.5

Da jeg beklagede ^W brokkede mig over inkompatible opgraderinger inkluderede jeg min seneste oplevelse med Atlassian’s Jira. Der tog jeg imidlertid fejl, idet min oplevelse skyldtes at opgraderingen ikke var færdiggjort.

Til gengæld er .NET 4.5 stadig et problem. Og det næstmest irriterende er at Microsoft faktisk prøver hjælpeløst at dække over problemet ved at kalde .NET 4.5 “highly compatible“:

highly-compatible

 

Problemet er bare, at kompatibilitet er binær; enten-eller. Så hvis man siger at noget er “highly compatible”, men ikke “fully compatible”, så siger man reelt “incompatible”.

(jeg ved godt at man kan tale om kompatibilitet på flere niveauer, f.eks. binær kompatibilitet og kilde kompatibilitet – her er der tale om en generel kompatibilitet)

Microsoft skriver at kompatibilitet er meget vigtigt for dem, men selv der må de indrømme at det ikke er lykkedes for dem. Da Microsoft så efterfølgende ville skrive mere om det pakkede de det ind i en masse pæne ord om hvor glade deres brugere er for .NET. Men for de berørte er der i det mindste en samling af inkompatibilitets punkter på MSDN.

Dette indlæg blev udgivet i Udvikling og tagget , , . Bogmærk permalinket.

Et svar til OK, så jeg tog fejl – men ikke om .NET 4.5

  1. Pingback: Windows | Hennings blog

Skriv et svar

Udfyld dine oplysninger nedenfor eller klik på et ikon for at logge ind:

WordPress.com Logo

Du kommenterer med din WordPress.com konto. Log Out / Skift )

Twitter picture

Du kommenterer med din Twitter konto. Log Out / Skift )

Facebook photo

Du kommenterer med din Facebook konto. Log Out / Skift )

Google+ photo

Du kommenterer med din Google+ konto. Log Out / Skift )

Connecting to %s